CakePHP 2.9.8 がリリースされました

CakePHP 2.9.8 Released の非公式日本語訳です。

CakePHP コアチームは CakePHP が 2.9.8 が利用可能になったことを発表いたします。これはコミュニティで報告されたいくつかの問題を修正する 2.9 ブランチのメンテナンスリリースです。

不具合修正

2.9.8 では以下の変更が行われています。各コミットの変更履歴を参照してください。

  • CakePHP に TLS 1.2 のサポートが追加されました。新しい TLS を使用するには PHP5.6 かそれ以上が必要です。
  • CSRF およびセキュリティトークンのフィールドが autocomplete=off になりました。これは新しいバージョンの Safari における戻るボタンの問題を解消します。
  • ControllerTestCase::testAction() は App.base が設定されている場合にも期待通りに動くようになりました。
  • Validation::notEmpty() は 3.x のように -0.0 を受け入れるようになりました。

2.9.8 への貢献者

このリリースの実現にご協力いただいたすべての貢献者の皆様にお礼申し上げます。

  • Livia Scapin
  • Marc Würth
  • Marcin Stramek
  • Mark Story
  • ndm2

私たちはいつでも、問題を報告したり、プルリクエストを出したり、あるいは文書の更新を行ってくださるすべての貢献者の皆様に感謝しております。

Share

コメントを残す

メールアドレスが公開されることはありません。